PDA

View Full Version : The Mission Objects window



No601_Swallow
Sep-08-2014, 09:01
Here's a question about mission objects.

A squadron mate said, after a mission yesterday, that he'd seen ships in the middle of the French countryside. Now, I am sure I placed no ships in the mission. Attach electrodes to my gonads and the answer will be the same. I placed no ships.

Sooooo... just to prove him wrong I opened up the .mis file in a text editor and searched the text for ships. I found 14 ships listed. Astonished (but only mildly - this is, after all, CloD), I loaded the mission up in the FMB and scrutinised the map. Nada. Then I thought about the "Mission Objects" window, which I don't usually have much use for, and sure enough the ships were in the list there. Also there were about 20 flak guns, when I know I only placed six.

Double-clicking on my six flak guns as listed in the mission objects window centres the map on those guns. It's actually a really useful way of checking out the mission. Double-clicking on the others just centres the map on empty fields. Different empty fields for each gun, almost as if the FMB is finding phantom flak guns. Similarly, the ships seem to be phantoms too. These objects all have coordinates and rotations in the .mis file, but I can't see them on the map and I didn't place them.

Any ideas? (I do have trouble with "pasting objects from list" since I often save objects which are still grouped with unwanted objects elsewhere on the map. Grrr. Up to and including entire airfields. But while this might explain why the ships got in there without me knowing - I pasted them in together with other sets of objects, why would they be invisible to me, and most others - and yet glimpsed, like a CLoD Marie Celeste, by one or two players?)

Is this just a Grrrr-Clod thing, is there a TF magic bullet to solve all of our problems, or am I finally going nuts?

And is the Mission Objects window really cool and unappreciated, or broken and not worth the time?

Mysticpuma
Sep-08-2014, 09:45
Hi Swallow, I'm sure one of our mission building gurus will be along to see if they can help when they read this. Maybe worth forwarding the mission with the issues by PM to either Salmo or Bolox and seeing of they have any ideas or fixes?
I'm sure there are many more experts out there but those are TF guys who I can recommend :)

Cheers, MP

No601_Swallow
Sep-08-2014, 12:11
Thanks for the reply Mr Puma!

I don't think it's a "mission with issues", exactly, in that it works fine. Apart from ghostly ships in the countryside (that I didn't see in mission!)...

I suppose I'm just still curious about the quirks in the FMB and why some things work and some things don't (like the ridiculous rigmarole of having to uncheck and then recheck (if and only if you're absolutely sure absolutely nothing is selected) the "rotate as group" option). I keep getting the impression that they were trying to build some huge revolutionary self-aware behemoth, which just kept falling apart at the seams. So much ambition, so many cool ways to try and do things (another for instance: copying and saving (and then repasting) groups of objects, etc. Indeed, the whole group-select adn group unselect mechanic. It's really intelligently done, but only if you can remember to jump through all the necessary hoops. Ditto the way the angles of rotation are formatted or the vectors for the wind. So so much! And don't get me started on my newest obsession - spline textures...!)

Anyway, this mission's .mis file will list lots of objects - but some of them don't - at least for me - appear on the map. And they weren't placed by me! (Unless I did it by accident, via a poorly specified group-paste...). I wish I could see in the .mis file why they might not actually appear. I wondered about subterranean z-coordinates, but with ships? Anyway...

Also, if the game is loading invisible and unnecessary objects, I suppose that would have a negative effect on performance. Ho hum.

The mission itself is OK - nothing special. A couple of submissions too. The whole lot is here (https://app.box.com/s/hrb5bwg32t4hb1o9a94k). If anyone wants to have a look, it should be unzipped into the DF folder. The scenery is in the "main" mission.

69th_Spiritus_Mortem
Sep-08-2014, 12:52
I had a similar issue when testing Relinquish. I would create spitfires to test train departure times and then delete the spitfire when done. Somehow after deleting one it moved it to an area of the map in FMB that I couldnt see so I thought it was gone. When testing online, there was this AI spitfire flying around somewhere and when I would take control of it, I would be flying over half water, half land but all just big squares.

If you can, select the "ghost" ships or AAA on the object list so it will move you over to your blank fields, then right click delete. It worked for me. Not sure if its the same issue but I deleted that spitfire and in reality CloD moved to an outside area of the map where I couldnt even go to. So once I selected it on the object list the map tried to move to it but stopped on the edge. Thats when someone smarter then me just told me to right click delete and all was solved.

Your group paste idea is very probable. Every time I would paste a group (AAA Battery) it would copy a single truck but it would be about 20 miles away. If I didn't remember to delete it and kept pasting away all of a sudden I would have single trucks in random places on the map far away from the AAA batteries I was pasting, and the closer you get to the edges of the map the more likely you think you delete them all but the ones outside the map become ghosts.

Salmo
Sep-08-2014, 23:58
I too have had issues with "non-selected" objects being saved in groups the they arear ?randomly when I paste the group into a mission. I've always assumed that I had accidently had them selected when I saved the group. With respect to your phanton ships; ships are placed at Z-offset zero by FMB (water level) is it possible that the phanton ships are just "under" some raised terrian area?