Results 1 to 7 of 7

Thread: No flags on entering server, quiting & re-joining doesn't help, with many error msgs

  1. #1
    Veteran Combat pilot
    Join Date
    May 2015
    Location
    Kansas City, Missouri area
    Posts
    291
    Post Thanks / Like
    Total Downloaded
    84.73 MB

    No flags on entering server, quiting & re-joining doesn't help, with many error msgs

    Here is a bug where the user joins the server and doesn't ever see any flags. Quitting and rejoining doesn't help, and even quitting/restarting Launcher doesn't help.

    It is happening with some frequency on the TWC Tobruk Server--sometimes or occasionally, but not every time the server runs.

    Once one player encounters this situation, it seems to be the same for everyone who tries to enter the server.

    Here is the error:

    Code:
    [13:30:51]	=================================================
    [13:30:51]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:30:51]	   at WYb4kT81Gj7ZXGv75lN9rAO6lAoq30CfWyWdUQD$AYNK.Armies()
    [13:30:51]	   at maddox.game.GameDef.selectArmiesRequest(IPlayer player)
    [13:30:51]	   at tsc$7$6e2KkzxKd7sYyezypfJniCO8D18_sQmVVCC5h7.xrL2HyB7JTQKUwx3mdaB3mfeOWykatPe7TePufAhQcTZ()
    [13:30:51]	   at tsc$7$6e2KkzxKd7sYyezypfJniCO8D18_sQmVVCC5h7.6bltGnnJuP$kVasanz7ZPUg(2LLuxAXLBYZPcnjosOJ2QZt2O$K90EkNj$47xmzSpxsD )
    [13:30:51]	   at eEUOw_Bh_JWOou3R5bj4wGeTAgubLXoIbmjdZmtlDoWP.GFweR0z1szbOFonytpl7m4k(2LLuxAXLBYZPcnjosOJ2QZt2O$K90EkNj$47xmzSpxsD )
    [13:30:51]	=================================================
    [13:30:51]	Server: XXXX joins the server.
    [13:30:51]	Server to [XXXX]: Welcome to Tobruk, XXXX
    So this is just at the moment the player joins the server.

    I found some interesting possibly/probably related errors a few minutes earlier in the log file:

    This series of errors is right at mission start, when it is loading all sorts of sub-missions, some stored on disk and some auto-generated. So it might be related to the load of one/some those sub-missions but it is hard to say for sure one way or the other.

    Code:
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.002
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.001
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.002
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.002
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.002
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.001
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.006
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.002
    [13:18:41]	
    [13:18:41]	=================================================
    [13:18:41]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:41]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:41]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:41]	   at EjMrfyQhsxWU_H4NmP_CAYIXeUK46d7iqDrl8IJF4Eg3.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:41]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:41]	=================================================
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.001
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.006
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.004
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.000
    [13:18:41]	Loading mission  ...
    [13:18:41]	Mission loaded. time = 0.000
    
    ... [skipping a bit, nothing special happening]
    
    [13:18:42]	Loading mission missions/Multi/Fatal/Tobruk_Campaign/Fresh input file/Battles/BattlePos100/PrimaryObjectives/Tobruk_Campaign-LOADONCALL-Blue-BuqBuqBritishArmorCamp-objective.mis ...
    [13:18:42]	Mission loaded. time = 0.002
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    [13:18:42]	=================================================
    [13:18:42]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:42]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , Int32 , jLf3KE6nG_F2qDpgSQtRe6ZXUAwY0fytyJruubV6mmZh )
    [13:18:42]	   at HAPhQOtkHu5I2jJ1WbwI086TurCeE2P2MPa73twygP4E.CrFgoYNMG4$JQYW9ninPTRQ()
    [13:18:42]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:42]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:42]	=================================================
    [13:18:42]	
    
    .... [many similar continue]
    
    [13:18:44]	
    [13:18:44]	=================================================
    [13:18:44]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:44]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.YrQJk7pb48wmv9LgiXa9n4E(mgVnVZnBJazg2JgGiF1hiwT8GgSJIeICQXQlZkiV0khl , m1gbamgvB4w1QQts0o7qsmypQH_Hs4jPuIBAQbuZy3v8 , Point3d& , Double , Int32 )
    [13:18:44]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.CJeOn__puEXrbjmUM$TUlTM(B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag , m1gbamgvB4w1QQts0o7qsmypQH_Hs4jPuIBAQbuZy3v8 , Double , mgVnVZnBJazg2JgGiF1hiwT8GgSJIeICQXQlZkiV0khl )
    [13:18:44]	   at 3Ygo7Qa7tMiCT8q0$Lr35h8JzFea9eaStbbRupeaJsxi.Ep6hG5SmBoloFjMfnZ0UzzOPMvt7ydznYmwtqnJqILwj(B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag , Double , mgVnVZnBJazg2JgGiF1hiwT8GgSJIeICQXQlZkiV0khl )
    [13:18:44]	   at ghdIPaaMtjYch3Tt$uK$kcrYknoy7zCNl$pdV0yeike$.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:44]	=================================================
    [13:18:44]	
    [13:18:44]	=================================================
    [13:18:44]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:44]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:44]	   at ghdIPaaMtjYch3Tt$uK$kcrYknoy7zCNl$pdV0yeike$.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , m1gbamgvB4w1QQts0o7qsmypQH_Hs4jPuIBAQbuZy3v8 , Single )
    [13:18:44]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:44]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:44]	   at r2OI3mO8lTtjJkKRp7K8MwKNxXu5gQSOHHbgYVYr1$Pq.bd4yFX08Rm8yF8aYXeBdmxo()
    [13:18:44]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:44]	=================================================
    [13:18:44]	
    [13:18:44]	=================================================
    [13:18:44]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:44]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:44]	   at JpjEQKLJRIKfLoEE29TElBLsSmMXG_RyUybFd4BUIeJMs06kdNthExQKUXMWs1V$4Q.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:44]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:44]	   at r2OI3mO8lTtjJkKRp7K8MwKNxXu5gQSOHHbgYVYr1$Pq.bd4yFX08Rm8yF8aYXeBdmxo()
    [13:18:44]	   at JpjEQKLJRIKfLoEE29TElBLsSmMXG_RyUybFd4BUIeJMs06kdNthExQKUXMWs1V$4Q.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:44]	=================================================
    [13:18:44]	
    [13:18:44]	=================================================
    [13:18:44]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:44]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:44]	   at JpjEQKLJRIKfLoEE29TElBLsSmMXG_RyUybFd4BUIeJMs06kdNthExQKUXMWs1V$4Q.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:44]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:44]	   at r2OI3mO8lTtjJkKRp7K8MwKNxXu5gQSOHHbgYVYr1$Pq.bd4yFX08Rm8yF8aYXeBdmxo()
    [13:18:44]	   at JpjEQKLJRIKfLoEE29TElBLsSmMXG_RyUybFd4BUIeJMs06kdNthExQKUXMWs1V$4Q.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:44]	=================================================
    [13:18:44]	
    [13:18:44]	=================================================
    [13:18:44]	System.NullReferenceException: Object reference not set to an instance of an object.
    [13:18:44]	   at vg85$ZzvVbq8HrhxCnDOTPQiuxgoE9PZv01yTqMtcWRE.7VouEozYYHZUxhVsVw4DYuw(Point3d& , Double , Int32 )
    [13:18:44]	   at ghdIPaaMtjYch3Tt$uK$kcrYknoy7zCNl$pdV0yeike$.CJeOn__puEXrbjmUM$TUlTM(Point3d& , Double , m1gbamgvB4w1QQts0o7qsmypQH_Hs4jPuIBAQbuZy3v8 , Single )
    [13:18:44]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.D5hW4kp0dBpFJ$cxPSsDGNs(c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx )
    [13:18:44]	   at c6xx7Z6mvwSFe3ti8_$jiqV0x9YkFrVQsKKx8gTa9NKx.4oqGDO0cBE3FEiPH$at1TI8()
    [13:18:44]	   at r2OI3mO8lTtjJkKRp7K8MwKNxXu5gQSOHHbgYVYr1$Pq.bd4yFX08Rm8yF8aYXeBdmxo()
    [13:18:44]	   at tooF84b31X1qkDTVZt$$5gvHpA4BCDJW8juU$Wl3E2hx.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at 4lFQrekintdZTkhMfDPtQkRUhCiE4wEk3Y$4KfiOXE3S.gT2xRAUYioNJspz1Vabv0$Q()
    [13:18:44]	   at B3ik9i8vEcErjO61EnV5pr8xSg_fKyjgLBB2LLZAsCag.9pab1TQFb7TOkw5gQ3ntgHA()
    [13:18:44]	=================================================
    [13:18:44]
    These same (or very similar) errors continue until 13:20:00--at a rate of many, many per second as you can see above. I only see two types "vg85$Zz" (mostly, especially towards the end) and "3Ygo7Qa7t" (more towards the beginning).

    I'll post the entire log file as soon as I figure out how to upload it somewhere.

    - I'm not sure the long string of errors above are related to not being able to enter the flag screen--it is only suspicious this unusual thing happened a few minutes before the problem

    - The long string of errors lasting several minutes definitely do not happen every time the server runs--and loads those very same missions or very similar ones--but only sometimes.
    System: Microsoft Windows 10 Pro 64 bit, 10.0.18362 N/A Build 18362, 20,437 MB |
    ASUS GeForce GTX 1060 3GB | Intel Core i5-2500 Quad-Core Processor 3.3 GHz 6 MB Cache LGA 1155 | Intel DB65AL motherboard | ARCTIC Freezer i11 CPU Cooler | SVGA 500 watt power supply | Microsoft Sidewinder 2 Force Feedback joystick

  2. #2
    Manual Creation Group
    Join Date
    May 2020
    Location
    Czech Republic
    Posts
    96
    Post Thanks / Like
    Total Downloaded
    71.72 MB

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    Hi,

    I have experienced this issue (no side selection flags on the initial server screen) several times.

    From what I have been able to observe, it always happened after I was kicked out of that server because of 'timeout'. When I immediately tried to connect to the same server again (without leaving the screen with the list of available servers), the flags were not shown.

    If I understand right, TWC_Flug wasn't able to connect to the same server at all. This was different for me. I think when I left the server selection screen first, then I returned back and tried to connect to the same server, the flags were shown again.

    To be honest, I'm not quite sure now but I think it was this way when I experienced this problem last time some time ago. It's possible something has changed here though.

    I'll try to check it again when it happens next time.

    Josef

  3. #3
    Supporting Member 9./JG52_J-HAT's Avatar
    Join Date
    May 2012
    Location
    Germany
    Posts
    798
    Post Thanks / Like
    Blog Entries
    16
    Total Downloaded
    0

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    I‘ve had this problem with different servers. It went away when I changed the Launcher64.exe compatibility mode to Windows 7.

    It is probably totally unrelated to your problem, as I was also having problems with the game not loading menu screens correctly. Or missions.
    i5 10600k @4.9 Ghz | RTX 2080 | 32 Gb RAM | Win10 64 bit | TrackIR 5 | VKB Gunfighter III | MFG Crosswind | Warthog Throttle

  4. #4
    Veteran Combat pilot
    Join Date
    May 2015
    Location
    Kansas City, Missouri area
    Posts
    291
    Post Thanks / Like
    Total Downloaded
    84.73 MB

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    Quote Originally Posted by Josef View Post
    Hi,

    I have experienced this issue (no side selection flags on the initial server screen) several times.

    From what I have been able to observe, it always happened after I was kicked out of that server because of 'timeout'.
    Yes, by my observation this is a different issue from both this (the ongoing "no flags" issue, where after you have lost connection to a server suddenly, by loss of internet, launcher crash, or similar and you don't get the flags on next connection but it works fine after), and also different from the "Wellington lock up" problem where the flags appeared but couldn't be selected (which seems to be completely solved by the recent patch).

    This is different from the normal "no flags" issue because it affects everyone who tries to join the server from that point forward, and the only way to solve it is to re-start the server.

    It happened on one of our servers again last night, and again the "no flags" problem was preceded by several minutes of those same two repeated errors, several times a second for about 3 minutes.

    I'm working on getting a logs.txt file uploaded, with all the details, but as near as I can tell the summary above has all the relevant info (of course I might have missed something). Many times repeated two different errors, then no flags after that.
    Last edited by TWC_Flug; Sep-15-2020 at 16:27.
    System: Microsoft Windows 10 Pro 64 bit, 10.0.18362 N/A Build 18362, 20,437 MB |
    ASUS GeForce GTX 1060 3GB | Intel Core i5-2500 Quad-Core Processor 3.3 GHz 6 MB Cache LGA 1155 | Intel DB65AL motherboard | ARCTIC Freezer i11 CPU Cooler | SVGA 500 watt power supply | Microsoft Sidewinder 2 Force Feedback joystick

  5. #5
    Veteran Combat pilot
    Join Date
    May 2015
    Location
    Kansas City, Missouri area
    Posts
    291
    Post Thanks / Like
    Total Downloaded
    84.73 MB

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    Here is a logs.txt file that has several incidents of this issue happening.

    * logs.txt - 60mb download

    You can find the different "outbreaks" of the errors by search for either 3Ygo7Qa7 or vg85$Zz.

    It looks like there are incidents around 13:18, 14:49, 16:19, 17:18, 18:48, 20:18, 23:12, 9:31, 11:07, and maybe a few others.

    Looking at all of these, it looks like it always happens at the same point in mission load--near the start, where everything is being initialized and loaded--so maybe we can figure out exactly what is triggering it. It looks like sometimes it happens during that mission load period, and sometimes not.
    Last edited by TWC_Flug; Sep-15-2020 at 18:39.
    System: Microsoft Windows 10 Pro 64 bit, 10.0.18362 N/A Build 18362, 20,437 MB |
    ASUS GeForce GTX 1060 3GB | Intel Core i5-2500 Quad-Core Processor 3.3 GHz 6 MB Cache LGA 1155 | Intel DB65AL motherboard | ARCTIC Freezer i11 CPU Cooler | SVGA 500 watt power supply | Microsoft Sidewinder 2 Force Feedback joystick

  6. #6
    Veteran Combat pilot
    Join Date
    May 2015
    Location
    Kansas City, Missouri area
    Posts
    291
    Post Thanks / Like
    Total Downloaded
    84.73 MB

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    So this always happens near the start of a new session. At that point there are roughly one million things happening on the server so it is really hard to pinpoint an exact cause. Dozens of sub-mission being loaded, various things being initialized, etc.

    Also I have only ever caught this happening on one of the three servers we're using to test & run this version of the server. And it happens only sometimes--not every time by any means.

    But here is a possible clue and a very, very kludg-y solution:

    Code:
    [13:19:48]	Stb_RemoveOffMapPlayers ERROR: System.NullReferenceException: Object reference not set to an instance of an object.
    [13:19:48]	   at WYb4kT81Gj7ZXGv75lN9rAO6lAoq30CfWyWdUQD$AYNK.Armies()
    [13:19:48]	   at StatsMission.Stb_RemoveOffMapPlayers(Object o)
    So WYb4kT81Gj7ZXGv75lN9rAO6lAoq30CfWyWdUQD$AYNK.Armie s() refers, I assume, to maddox.game.GameWorld.Armies(), which is called by GamePlay.gpArmies(), which is in the Stb_RemoveOffMapPlayers method which threw the error above.

    So after this "thing" happens, whatever it is, ANY reference to .Armies() throws a System.NullReferenceException. So that is why everything is broken.

    For now I'm just going to kludge up our missions so that if that error is encountered they immediately restart.
    Last edited by TWC_Flug; Sep-15-2020 at 19:08.
    System: Microsoft Windows 10 Pro 64 bit, 10.0.18362 N/A Build 18362, 20,437 MB |
    ASUS GeForce GTX 1060 3GB | Intel Core i5-2500 Quad-Core Processor 3.3 GHz 6 MB Cache LGA 1155 | Intel DB65AL motherboard | ARCTIC Freezer i11 CPU Cooler | SVGA 500 watt power supply | Microsoft Sidewinder 2 Force Feedback joystick

  7. #7
    Team Fusion ATAG_Oskar's Avatar
    Join Date
    Nov 2017
    Location
    Canada
    Posts
    611
    Post Thanks / Like
    Total Downloaded
    704.46 MB

    Re: No flags on entering server, quiting & re-joining doesn't help, with many error m

    Is it just the one function? Can you add this check?

    private void Stb_RemoveOffMapPlayers(Object o) {

    if (o != null) {

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •