Results 1 to 5 of 5

Thread: Controlls issue: Button and Button+Modifiers pressing

  1. #1
    Ace Rostic's Avatar
    Join Date
    Sep 2015
    Posts
    1,680
    Post Thanks / Like
    Total Downloaded
    9.73 MB

    Controlls issue: Button and Button+Modifiers pressing

    Did not played Cliffs for several week. Today I finally descided to get some fun, but I spotted problems even before start engine.
    I have a lot of actions set to single button and other actions to the same button with modifier. Trying to set chocks in I pressed "Ctrl+B" and found out that breaks also responded on this keys combo. But breaks should be engaged only by pressing single button "B". Same trouble with weapons. When I dropping bomb by pressing "Ctrl+Space" machine guns starts shooting, but they should shoot only when just "Space" pressed.

    To my opinion this is serious issue, because this eliminates usage of just single buttons because they are affected when keys combo pressed.

    Game version: 5.026
    Intel Core i7 8700K 3.7Ghz, DDR4 16Gb 2666Mhz, Asus Prime Z370-A, ADATA XPG SX8200 240Gb (PCIe Gen3x4), RTX 2060 6Gb

  2. Likes Karaya liked this post
  3. #2
    Supporting Member Karaya's Avatar
    Join Date
    Sep 2013
    Posts
    1,551
    Post Thanks / Like
    Total Downloaded
    117.73 MB

    Re: Controlls issue: Button and Button+Modifiers pressing

    Strongly agree
    This kinda defeats the purpose of being able to make button combo assignments.

  4. #3
    Team Fusion Artist's Avatar
    Join Date
    Mar 2010
    Posts
    2,519
    Post Thanks / Like
    Total Downloaded
    319.55 MB

    Re: Controlls issue: Button and Button+Modifiers pressing

    Just checked - not happening here. Full Wheel Brake "B" and Signal Ground Crew to Insert or Remove Chocks: "Control B" work separately just as they should.

    I'm afraid there's something on your computer. Another program interfering?

  5. Likes Rostic liked this post
  6. #4
    Ace Rostic's Avatar
    Join Date
    Sep 2015
    Posts
    1,680
    Post Thanks / Like
    Total Downloaded
    9.73 MB

    Re: Controlls issue: Button and Button+Modifiers pressing

    Quote Originally Posted by Artist View Post
    Just checked - not happening here. Full Wheel Brake "B" and Signal Ground Crew to Insert or Remove Chocks: "Control B" work separately just as they should.

    I'm afraid there's something on your computer. Another program interfering?
    Thank you. You a right. It was on my side... The problem was found when I tryed to setup new button for Toggling info windows. Every time I opened window where I shoud press button that I want for action, there always were "joystic-throtle-quuadrant-blabla-button7". It was strange because I never used that joystic in Cliffs but I put an eye on that device and found out that one of lever a below analog zero position. One of the features of Throttle quadrant that this joystick emulates button press when axis at lowest position. But this time it was in between analog zero and lowest possible position, so this device permanently generated button press event. So I simply pushed lever to upper position and problem gone.

    After that I checked this with other joystick and this happened too. Yeah, conditions are very rarely when this bug can be replicated, but maybe something wrong with controls code.
    So to replicate this in cockpit start simultateously pressing any unassigned button on your joystick and at the same time (with another hand) pres keys combo (Ctrl+B for example and it will engage two action: breaks and chockes toggle).
    Intel Core i7 8700K 3.7Ghz, DDR4 16Gb 2666Mhz, Asus Prime Z370-A, ADATA XPG SX8200 240Gb (PCIe Gen3x4), RTX 2060 6Gb

  7. #5
    Supporting Member Karaya's Avatar
    Join Date
    Sep 2013
    Posts
    1,551
    Post Thanks / Like
    Total Downloaded
    117.73 MB

    Re: Controlls issue: Button and Button+Modifiers pressing

    Quote Originally Posted by Artist View Post
    Another program interfering?
    I think in my case it was a third party button mapper that may cause the issue. Will have to try again with the tool off.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •